Unable to add service plans to facilities
Incident Report for PASS Training & Compliance
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 30, 2019 - 12:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jul 30, 2019 - 12:14 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 30, 2019 - 11:12 EDT
This incident affected: PASS Tools.